Installing OpenClinica 2.2.1 

on Windows

Screenshots used as examples and might not match exactly what is written in the instructions.   Please follow the instructions as they are written.
Note: Many windows systems are not configured to show the file extensions by default. In order to use this guide, you will need to be able to see the file extensions. To configure this behavior, open a Windows Explorer window. Click Tools > Folder Options. Go to the View tab, and in Advanced settings uncheck the ‘Hide extensions for known file types’.
This installation was performed successfully on Windows Server 2003 Standard Edition SP1. 

This installation was performed successfully on Windows XP Professional Version 2002 SP2. 

The system should work on Windows 2000 Professional and compatible systems, but has not been tested on other Windows platforms.

NOTE: All characters are case sensitive.  Please be aware of any additional white space between or after characters this may cause installation errors.  

NOTE: This software distribution will also work for Linux based systems; however Akaza provides a separate Linux distribution in tarball format, available at http://www.openclinica.org
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1. About OpenClinica

 

Professional Open Source Solutions for the Clinical Research Enterprise

 

OpenClinica is a software platform for protocol configuration, design of Case Report Forms (CRFs), and electronic data capture, retrieval, and management.  It is extensible, modular, standards-based, and open source.

More about OpenClinica: http://www.OpenClinica.org
 

Software License

OpenClinica is distributed under the GNU Lesser General Public License (GNU LGPL).

For details, please see: http://www.openclinica.org/license or the LICENSE.txt file in this distribution.

 

Developer and Contact Information

Akaza Research, based in Cambridge, MA, provides open informatics solutions that address the needs of academic and non-profit institutions engaged in clinical, healthcare and biomedical research. 

 

Akaza utilizes internally -and community- developed open source software and open standards to provide professional services for the clinical research enterprise. These open solutions enable Akaza's customers to effectively address the challenges of data management, compliance, and interoperability in the modern clinical and healthcare research environment.

 

Akaza Research

One Kendall Square

Bldg. 400, 4th Floor

Cambridge, MA 02139

phone: 617.621.8585

fax: 617.621.0065

email: contact@akazaresearch.com

 

For more about Akaza's products and initiatives see: 

http://www.akazaresearch.com
http://www.OpenClinica.org
2. Software Dependencies

OpenClinica runs on top of any Servlet/JSP container that implements the Servlet 2.4 and JavaServer Pages 2.0 specifications from the Java Community Process.  It was developed to run on Apache Jakarta Tomcat 5.5.23.

 

Currently, OpenClinica also runs on top of the Postgres relational database, but can be modified to work on top of an Oracle relational database.  Using a JDBC (Java Database Connectivity) driver, the database connects to the web application and provides the data to the end-user.

 

Required:
Jakarta Tomcat 5.5.26
Java 2 Standard Edition Development Kit 5.0 Update 14
Postgres 8.2.5
Postgres JDBC Driver Version 8.1-405 JDBC 3

 

This installation guide will show you how to acquire and setup each of the required components and configure the OpenClinica web application.

Note: The software stack OpenClinica runs on is open source, and most open source projects release minor versions and revisions often. Sometimes only a matter of weeks may separate the release of two adjacent versions of the software.
For this release, the latest stable version of each component was used in integrated testing, and its revision number is referenced in this document. In some cases, the revision number mentioned may no longer be available. For the most part, you should be able to use later minor versions and revisions of the same software without incident. For instance, if the install guide uses PostgreSQL 8.2.5, PostgreSQL 8.2.6 should work as well.  PostgreSQL 8.3 might not work.
We recommend that you record the revision number you use. If you have concerns about a particular combination, please post your question to the users@openclinica.org mailing list.

3. Install Java
OpenClinica 2.2.1 is designed to run on a Java 2 SDK 1.5x platform.  To avoid conflicts with other versions of Java, you should clear out any other Java installations on the system.
· Go to Start>Control Panel>Add Remove Programs, and remove all Java JRE and SDKs.

· Download J2SE Development Kit 5.0 Update 14
· Setup the Java 2 SDK

	Windows offline installation (EXE)

	Filename: jdk-1_5_0_14-windows-i586-p.exe

	Size: 50.62 MB

	Website: http://java.sun.com/javase/downloads/index_jdk5.jsp


· Run jdk-1_5_0_14-windows-i586-p.exe
License Agreement 
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· Accept the terms of the licensing agreement.

· Click Next >
Custom Setup
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· Click Change…

· Install to the folder c:\jdk1.5.0_14\

· Click Next >

· Setup will begin transferring files.
Note: The J2SE Runtime Environment w/European Languages installation wizard will pop up.  You can install it, but it is not necessary for OpenClinica.  You may hit Cancel and then hit Yes to move forward.  Or, you can choose to install it.
Installation Completed
· Click Finish

· You may see a window asking you to restart your computer, click yes and restart your machine.

Create JAVA_HOME Environment Variable
· Right click on My Computer, and select Properties

· Select the Advanced tab

· Click the Environment Variables button.

· In the System Variables group, click the New button

· Create a JAVA_HOME variable that has the path to the jdk:
· Variable Name = JAVA_HOME

· Variable Value = c:\jdk1.5.0_14
· Click OK

· Click OK

· Click OK
4. Install PostgreSQL
The default installation of OpenClinica uses a PostgreSQL database. PostgreSQL is an open source application and can be installed to the Window platform as follows.
· Download postgresql-8.2.5-1.zip
	Windows binary distribution (ZIP)

	Filename: postgresql-8.2.5-1.zip

	Size: 22.6 MB

	Website: http://www.postgresql.org/ftp/binary/v8.2.5/win32/


Note: You will be presented with mirrors.  Select one in your country and it will download 

Extract Postgres Installation Files 
· Extract the files

· Create a folder c:\postgres.install

· Extract archive there, you should end up with some Windows installation files

· Run postgresql-8.2.msi, the PostgreSQL Installation Wizard Opens=

PostgreSQL Setup
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· Check “Write detailed installation log to postgresgl-8.2.log in the current directory.”
· This is important as it will keep details of everything that goes on with the database.  
· Click Start >

Welcome to the PostgreSQL Installation Wizard

· Click Next >

Installation Notes
· Click Next >

Installation Options
· Click Next >

Service Configuration 
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· The service account is the account that runs the PostgreSQL database server.
· Create an account name called postgres and set a strong password.
· You will need this when administering PostgreSQL as a service, but you will not need it for the rest of the installation.
· Click Next >

Create User Postgres
· A window may display the following message: “Account Error: User MACHINENAME/postgres can not be found. Would you like the account to be created for you?”

· This is normal, click Yes. 

Initialize Database Cluster
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· Set and verify a strong password for the database superuser postgres. 

· Record this password; you will need this username and password when setting up the OpenClinica database.

· Click Next >
Note: This is the internal database user name and not the service account.  For security reasons, the password should NOT be the same as the service account.
Enable Procedural Languages
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· Uncheck the PL/pgsql language. (The database scripts you will run later will create this procedural language, and if it is created in this step those scripts will fail.)
· Click Next >

 

Enable Contrib Modules 
· Click Next>

Ready to Install 
· Click Next>

Installation Complete
· Click Finish.

5. Install Tomcat
· Download Apache Tomcat 5.5.25, use the Windows Service Installer version.
	Windows binary distribution (EXE)

	Filename: apache-tomcat-5.5.25.exe

	Size: 4.85 MB

	Website: http://tomcat.apache.org/download-55.cgi


· Create a folder c:\tomcat5

· Run apache-tomcat-5.5.25.exe, the Apache Tomcat Setup installation wizard appears.

Tomcat Setup
· Click Next >

License Agreement
· Click I Agree

Choose Components
· Choose Normal from the “Select the type of install” dropdown list.

· Click Next >

Choose Install Location
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· Edit destination folder to read C:\tomcat5
· Click Next >

 
Set Configuration Options
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· Verify the HTTP Connector Port is 8080

· Type a password for the admin login account. You will need this password to administer the Apache Tomcat server, and to get to the Tomcat Manager.

· Click Next >

Locate the Java Virtual Machine
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· The path to JVM should be c:\jdk1.5.0_14\
Note: Do not use c:\ jdk1.5.0_14\jre, Tomcat will still install, but will be missing libraries you need to run OpenClinica.
· Click Install

· Setup will begin transferring files.

Install Complete
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· Check the Run Apache Tomcat checkbox.

· Uncheck the Show Readme checkboxes.

· Click Finish.  Tomcat is now installed

 

Create CATALINA_HOME Environment Variable
· Right click on My Computer, and select Properties

· Select the Advanced tab

· Click the Environment Variables button. 

· In the System Variables group, click the New button

· Create a CATALINA_HOME variable that has the path to the jdk (should be CATALINA_HOME=C:\tomcat5).
· Click OK

· Click OK

· Click OK
6. Install OpenClinica Package

To install OpenClinica, you must first acquire the package and install it on the server.
	Download OpenClinica 2.2.1 (Windows package)

	Filename: OpenClinica-2.2.1.zip (ZIP)

	Website: http://openclinica.org (you must register)


 Extract OpenClinica Package
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· Extract the files

· Create an install folder c:\oc\

· Extract archive into c:\openclinica\, you should end up with a folder c:\oc\OpenClinica-2.2.1\ which contains the distribution package.
Note: Due to documentation changes prior to release, your distribution package may have different documentation files in this root directory.

7. Configure PostgreSQL
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· Open pgAdminIII. Go to Start>Programs>PostgreSQL 8.2 > pgAdminIII. The pgAdminIII interface opens. Note: ‘Tip of the day popup opens, click “close” button.
· Right click on the PostgreSQL Database Server and connect to the database server.

· Login to the database server. Enter the password you setup in the PostgreSQL installation for the Initialize Database Cluster section.

Create a Database
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· Right click the Databases item and select New Database.
· Database properties: Name the database openclinica and set the owner to postgres.
8. Create Database Tables
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· Select the OpenClinica database. Click Tools>Query tool to open the SQL editor.

· Select File>Open from the menu;
· Open and Execute create_db_role.sql in the C:\oc\OpenClinica-2.2.1\config\database\PostgreSQL\2.2.1\install folder. 

· Select Query>Execute
· You will see a message in the “History” window indicating the query has completed.

· Select File>Open from the menu;
· Open and Execute create_database_2_2_with_data.sql in the C:\oc\OpenClinica-2.2.1\config\database\PostgreSQL\2.2.1\install folder.
· Select Query>Execute
· You will see a message in the “History” window indicating the query has completed.

Note: The initial file creates a user named “clinica” with the password “clinica” and the second builds the database. This account owns all the entities created in the process.  Other applications can connect to the database with the username clinica and password.  If you change this username, you must modify several configuration files (See ‘Configure the Web Application’).  
Note: you may receive warnings or error messages while executing these scripts, this is normal and should not affect installation.

Note: The script also creates an empty table called “extract_data_table” which is the datamart used for querying data.  Please follow the instructions on setting up the datamart later in this guide.

· Close pgAdminIII
9. Configuring the Web Application

Start Tomcat
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· Make sure Tomcat is running.

· You should see the Tomcat monitor in the system tray. Click this to bring up the Apache Tomcat properties window. (You can also use the Windows services applet)
· Open a browser to http://localhost:8080/manager/html, and enter your tomcat password. This is the password you entered in step 8.
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· In the ‘WAR’ file to deploy section, click Browse and find the OpenClinica.war file in C:\oc\OpenClinica-2.2.1\distribution folder.

· Click Deploy

· OpenClinica should be listed in the Applications section.

NOTE: If OpenClinica does not get deployed properly you can deploy it in another way.  Please copy the OpenClinica.war file from c:\oc\OpenClinica-2.2.1\distribution and paste it in the c:\tomcat5\webapps folder.

Create Data Folders
· Create a directory c:\tomcat5\openclinica.data
· Create a folder "crf" under the path C:\tomcat5\openclinica.data
· This directory will store all CRFs (original and subsequent versions) and dataset files. 

Modify Configuration Files for Server Specific Settings
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· Open C:\tomcat5\webapps\OpenClinica\properties\datainfo.properties file in WordPad and modify it to use the IP addresses of your server, database, and mail servers. 

· You must be sure to comment out the Linux filePath and uncomment the windows filePath, and be sure the filePath references the data folder you just created. The windows file path starts with a c:\. Use a ‘#’ character at the start of the line to comment it out.
· Be sure the filePath references the data folder you just created.
 

Note: The screenshots is an example and could look different.  Also, they use the loop back address (localhost or 127.0.0.1), you can use this address to verify the installation on the install machine, but you will have to go back and change this to the server’s address before you can use the application on an intranet or over the web.
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· Modify OpenClinica.xml

· Open C:\tomcat5\conf\Catalina\localhost\OpenClinica.xml in your text editor.

· Modify the path and docbase attributes of the Context node to “/OpenClinica”

· If necessary, modify the value attribute of the propertiesDir node to “c:\\tomcat5\\webapps\\OpenClinica\\properties\\” (Note the escaped backslashes.)  Make sure to remove the <!-- and --> from the front and back of the path.
· Copy C:\oc\OpenClinica-2.2.1\config\libraries\postgresql-8.1-405.jdbc3.jar to C:\tomcat5\common\lib

· Stop Tomcat

· Start Tomcat
10. Setting up the Datamart

In order to use the Extract Data features, you need to setup the application’s datamart. This pulls data from various tables so it can be queried. You can create the datamart manually by executing the pg_data_warehouse.sql script, located in OpenClinica’s conf folder.

 

You will probably want to setup this script to execute regularly, such as on a daily basis. To do this, you will want to execute the following AT commands on the server. These will setup the script to be executed daily at midnight.

 

· Execute the C:\oc\OpenClinica-2.2.1\config\datawarehouse \setup_data_warehouse.bat batch script. This sets seven scheduled tasks, one for each day of the week. One of these commands looks like this:

 

AT 00:00 /every:SUNDAY java -cp C:\oc\OpenClinica-2.2.1\config;C:\oc\OpenClinica-2.2.1\config\postgresql-8.1-41.jdbc3.jar UpdateWarehouseJDBC C:\oc\OpenClinica-2.2.1\config\update_warehouse_jdbc.properties

 

· You may need to change the paths in setup_data_warehouse.bat to fit your installation folders. Note: If you have changed the location or name of the OpenClinica package you MUST edit this file to refer to the new location.
 

· You can run AT with no parameters to verify the jobs have been loaded.

 

· You may need to change the parameters in update_warehouse_jdbc.properties with the location of the pg_data_warehouse.sql file, and the database name, user, and password. 

11. Verify your Environment
 

· Open a command line and type “set JAVA_HOME” and verify the variable is set to your Java directory (in this case probably JAVA_HOME=C:\ jdk1.5.0_14) 

 

· Open a command line and type “set CATALINA_HOME” and verify the variable is set to your Tomcat directory (in this case probably CATALINA_HOME=c:\tomcat5) 

 

· Open a web browser on the server to http://localhost:8080 and verify Tomcat is up and running.

 

· Open a web browser on the server to http://localhost:8080/OpenClinica and verify the web application loads. You should see the OpenClinica login screen. 

 

· Login to the system. The default username is root and the password is 12345678. Note: If you get a blank screen after trying to login, Tomcat was probably not able to make a connection to the database, or the database is empty or missing account information. For more information on troubleshooting, refer to the OpenClinica wiki. http://openclinica.org/dokuwiki/doku.php?id=publicwiki:faq
· Add some users. Don’t forget to change the root user’s password.
 

At this point the application has been installed correctly. You should now spend some time setting up a secure environment, and then creating your studies.

 

· You should change the password for the database. You will need to go into pgAdminIII and change it for the clinica user, and then go into the C:\tomcat5\conf\Catalina\localhostOpenClinica.xml file, change the connectionPassword attribute of the Realm node, and change the value of  password in ResourceParams node.

 

· You should set up SSL for Tomcat. More information is available here: http://tomcat.apache.org/tomcat-5.0-doc/ssl-howto.html
 

· You will need to change the localhost URLs in the configuration files (datainfo.properties and OpenClinica.xml) to match your desired server settings. If you are planning on using OpenClinica over the web, this will need to be your server’s or proxies URL and you may need to open the Tomcat port.

 

· Enterprise support services, mailing lists, and additional resources for OpenClinica are available at http://www.openclinica.org.

 

12. Troubleshooting
 

· Please note, these instructions are for new installations of OpenClinica 2.2.1. There is a patch package available for OpenClinica 2.0.1 users who would like to upgrade. If you are using a version of OpenClinica older that 2.0.1, refer to the 2.0.1 package for instructions on upgrading to 2.2.
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« what you were doing,
« whentt happened,
 and any other detas (Ike error messages) that might be ipartant,

Tharks,

The OpenCirica Developmert Team





· If you encounter a screen similar to the one above, you can browse the tomcat logs in c:\tomcat5\logs to determine the source of the exception. This will help you troubleshoot the issue.
· For exceptions caused by the JDBC driver try copying the jdbc driver files from C:\Program Files\PostgreSQL\8.2.5-1\jdbc to C:\tomcat5\common\lib
· For complete details about this release, and a list of known issues, please refer to the README.txt file.
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