Installing OpenClinica 3.0.4 

on Windows

Screenshots used as examples and might not match exactly what is written in the instructions.   Please follow the instructions as they are written.
Note: Many windows systems are not configured to show the file extensions by default. In order to use this guide, you will need to be able to see the file extensions. To configure this behavior, open a Windows Explorer window. Click Tools > Folder Options. Go to the View tab, and in Advanced settings uncheck the ‘Hide extensions for known file types’.
This installation was performed successfully on Windows Server 2003 Standard Edition SP2.
This installation was performed successfully on Windows Server 2003 Standard Edition SP1. 

This installation was performed successfully on Windows XP Professional Version 2002 SP2. 

The system should work on Windows 2000 Professional and compatible systems, but has not been tested on other Windows platforms.

NOTE: All characters are case sensitive.  Please be aware of any additional white space between or after characters this may cause installation errors.  

NOTE: This software distribution will also work for Linux based systems; however Akaza provides a separate Linux distribution in tarball format, available at http://www.openclinica.org
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1. About OpenClinica

 

Professional Open Source Solutions for the Clinical Research Enterprise

OpenClinica: Open Source Software Platform for Managing Clinical Research Studies Professional Open Source Solutions for the Clinical Research Enterprise

OpenClinica is a free, open source clinical trial software platform for Electronic Data Capture (EDC) clinical data management in clinical research. The software is web-based and designed to support all types of clinical studies in diverse research settings. From the ground up, OpenClinica is built on leading independent standards to achieve high levels of interoperability. Its modular architecture and transparent, collaborative development model offer outstanding flexibility while supporting a robust, enterprise-quality solution.

More about OpenClinica: http://www.OpenClinica.org

Software License

OpenClinica is distributed under the GNU Lesser General Public License (GNU LGPL). For details see: http://www.openclinica.org/license or LICENSE.txt distributed with this distribution.

Developer and Contact Information

Akaza Research, based in Cambridge, MA, provides clinical trials informatics solutions based on OpenClinica, the world's most widely used open source clinical trials software.

Akaza Research 
460 Totten Pond Rd 
Suite 200 
Waltham, MA 02451 
email: contact@akazaresearch.com

For more about Akaza’s products and services see: 
http://www.akazaresearch.com/
and
http://www.OpenClinica.org/

2. Software Dependencies

OpenClinica runs on top of any Servlet/JSP container that implements the Servlet 2.4 and JavaServer Pages 2.0 specifications from the Java Community Process.  It was developed to run on Apache Jakarta Tomcat 5.5.27.

 

Currently, OpenClinica runs on top of either the Postgres relational database or an Oracle relational database.  Using a JDBC (Java Database Connectivity) driver, the database connects to the web application and provides the data to the end-user.

 

Required for new installs:
Jakarta Tomcat 6.0.20
Java 2 Standard Edition Development Kit 6.0 Update 16
Postgres 8.4.1 or Oracle 10g
 

This installation guide will show you how to acquire and setup each of the required components and configure the OpenClinica web application.

Note: The software stack OpenClinica runs on is open source, and most open source projects release minor versions and revisions often. Sometimes only a matter of weeks may separate the release of two adjacent versions of the software.
For this release, the latest stable version of each component was used in integrated testing, and its revision number is referenced in this document. In some cases, the revision number mentioned may no longer be available. For the most part, you should be able to use later minor versions and revisions of the same software without incident. For instance, if the install guide uses PostgreSQL 8.4.1, PostgreSQL 8.4.2 should work as well. 

We recommend that you record the revision number you use. If you have concerns about a particular combination, please post your question to the users@openclinica.org mailing list.

3. Install Java
OpenClinica 3.0.4 is designed to run on a Java 2 SDK 1.6x platform.  To avoid conflicts with other versions of Java, you should clear out any other Java installations on the system.
· Go to Start>Control Panel>Add Remove Programs, and remove all Java JRE and SDKs.

· Download J2SE Development Kit 6.0 Update 16
· Setup the Java 2 SDK

	Windows offline installation (EXE)

	Filename: jdk-6u16-windows-i586.exe

	Size: 73.54 MB

	Website: https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=jdk-6u16-oth-JPR@CDS-CDS_Developer 


· Run jdk-1_6_0_16-windows-i586-p.exe

License Agreement 
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· Click Accept >
Custom Setup
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· Click Change…

· Install to the folder c:\oc\jdk1.6.0_16\

· Click OK

· Click Next >
· You will see another page for installing the JRE6.  Press Cancel and then Yes.
· Setup will begin transferring files.
Installation Completed
· Click Cancel

· Click Yes

· Click Finish

· You may see a window asking you to restart your computer, click yes and restart your machine.
4. Install PostgreSQL
The default installation of OpenClinica uses a PostgreSQL database. PostgreSQL is an open source application and can be installed to the Window platform as follows.
· Download postgresql-8.4.1-1windows.exe
	Windows binary distribution (ZIP)

	Filename: postgresql-8.4.1-1-windows.exe

	Size: 25.8 MB

	Website: http://svn.akazaresearch.com/oc/software/OpenClinica-3.0.4/windows    


· Run postgresql-8.4.1-1-windows.exe, the PostgreSQL Installation Wizard Opens.
Setup
· Click Next.
Installation Directory

· Click Next.
Data Directory

· Click Next.
Password
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· Enter a password for the postgres user

· Click Next.
Port
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· Port should be 5432

· Click Next.
Advanced Options
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· Use Default locale

· Uncheck the checkbox next to Install pl/pgsql in template1 database

· Click Next.
Ready to Install 
· Click Next>

Setup
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· Uncheck Stackbuilder

· Click Finish>

5. Install Tomcat
· Download Apache Tomcat 6.0.20, use the Windows Service Installer version.
	Windows binary distribution (EXE)

	Filename: apache-tomcat-6.0.20.exe

	Size: 5.6 MB

	Website: http://tomcat.apache.org/download-60.cgi 


· Create a folder c:\oc\tomcat

· Run apache-tomcat-6.0.20.exe, the Apache Tomcat Setup installation wizard appears.

Tomcat Setup
· Click Next >

License Agreement
· Click I Agree

Choose Components
· Choose Normal from the “Select the type of install” dropdown list.

· Click Next >

Choose Install Location
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· Edit destination folder to read C:\oc\tomcat
· Click Next >

 

Set Configuration Options
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· Verify the HTTP Connector Port is 8080

· Type a password for the admin login account. You will need this password to administer the Apache Tomcat server, and to get to the Tomcat Manager.

· Click Next >

Locate the Java Virtual Machine
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· The path to JVM should be c:\oc\jdk1.6.0_16\
Note: Do not use c:\ oc\jdk1.6.0_16\jre, Tomcat will still install, but will be missing libraries you need to run OpenClinica.
· Click Install

· Setup will begin transferring files.

Install Complete
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· Check the Run Apache Tomcat checkbox.

· Uncheck the Show Readme checkboxes.

· Click Finish.  Tomcat is now installed
 

6. Install OpenClinica Package

To install OpenClinica, you must first acquire the package and install it on the server.
	Download OpenClinica 3.0.4 (Windows package)

	Filename: OpenClinica-3.0.4.zip (ZIP)

	Website: http://openclinica.org (you must register)


 Extract OpenClinica Package
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· Extract archive into c:\oc, you should end up with a folder c:\oc\OpenClinica-3.0.4\ which contains the distribution package.
Note: Due to documentation changes prior to release, your distribution package may have different documentation files in this root directory.

7. Configure PostgreSQL
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· Open pgAdminIII. Go to Start>Programs>PostgreSQL 8.4 > pgAdminIII. The pgAdminIII interface opens. Note: ‘Tip of the day popup opens, click “close” button.
· Right click on the PostgreSQL Database Server and connect to the database server.

· Login to the database server. Enter the password you setup in the PostgreSQL installation.

Create a Database
· Select the postgres database. Click Tools>Query tool to open the SQL editor.

· Select File>Open from the menu; (if you receive a message asking you if you want to save, click No)
· Open and Execute create_user_and_db_3.0.4.sql in the C:\oc\OpenClinica-3.0.4\config\database\PostgreSQL\3.0.4\install folder. 

· Select Query>Execute
· You will see a message in the “History” window indicating the query has completed.

8. Configuring the Web Application

Start Tomcat
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· Make sure Tomcat is running.

· You should see the Tomcat monitor in the system tray. Click this to bring up the Apache Tomcat properties window. (You can also use the Windows services applet)
· Click on the “Java” tab

· Put “1280” into the “Maximum memory pool” section

· If you are going to have more then one instance of OpenClinica used by this Tomcat installation add “-XX:MaxPermSize=180m” on a new line in the JAVA Options text entry on the “Java” tab.

· Make a directory called c:\oc\tomcat\oldwebapps

· Copy all files currently in c:\oc\tomcat\webapps to c:\oc\tomcat\oldwebapps

· Copy c:\oc\OpenClinica-3.0.4\distributon\OpenClinica.war to c:\oc\tomcat\webapps

· Once copied go to c:\oc\tomcat\webapps and see if there is a folder called OpenClinica. Wait a minute and if no folder is present restart tomcat.  Please give some time to allow the war file to fully deploy.
· Once OpenClinica.war is fully deployed delete the OpenClinica.war file.

· Stop Tomcat
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Create Data Folders
· Create a directory c:\oc\tomcat\openclinica.data
· This directory will store all CRFs (original and subsequent versions), Rules and dataset files. 
Modify Configuration Files for Server Specific Settings
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· Open C:\oc\tomcat\webapps\OpenClinica\WEB-INF\classes\datainfo.properties file in WordPad and modify it to use the IP addresses of your server, database, and mail servers. You can also modify your default Facility Information.
· You must be sure to comment out the Linux filePath and uncomment the windows filePath, and be sure the filePath references the data folder you just created. The windows file path starts with a c:\. Use a ‘#’ character at the start of the line to comment it out.

· Be sure the filePath references the data folder you just created.

· Go to database configuration section of the file and enter the following information

datasource.driver=org.postgresql.Driver

datasource.url=jdbc:postgresql://localhost:5432/openclinica

datasource.username=clinica

datasource.password=clinica

hibernate.dialect=org.hibernate.dialect.PostgreSQLDialect
 

Note: The screenshots use the loop back address (localhost or 127.0.0.1), you can use this address to verify the installation on the install machine, but you will have to go back and change this to the server’s address before you can use the application on an intranet or over the web.
· Configure location of log files as well as prefix of the log file names by changing
 log.dir=${catalina.home}/logs/openclinica

· There are many other configuration options in this file.  Please read the instructions in the file for more information.  This installation document was created to get the application up and running in as few steps as possible.


· If you are using Oracle, uncomment the Oracle specific configurations and comment out the PostgreSQL specific configurations


· Save the file


· Start Tomcat
9. Verify your Environment
 

· Open a web browser on the server to http://localhost:8080 and verify Tomcat is up and running.

 

· Open a web browser on the server to http://localhost:8080/OpenClinica and verify the web application loads. You should see the OpenClinica login screen. 

 

· Login to the system. The default username is root and the password is 12345678. Note: If you get a blank screen after trying to login, Tomcat was probably not able to make a connection to the database, or the database is empty or missing account information. For more information on troubleshooting, refer to the OpenClinica wiki. http://openclinica.org/dokuwiki/doku.php?id=publicwiki:faq
· Add a user that has the same privileges as root. Login as the new user and remove the Root user account so no one will have access to it. 

 

At this point the application has been installed correctly. You should now spend some time setting up a secure environment, and then creating your studies.

 

· You should change the password for the database. You will need to go into pgAdminIII and change it for the clinica user, and then go into the C:\oc\tomcat\webapps\OpenClinica\WEB-INF\classes\datainfo.properties, change the password in #2.
 

· You should set up SSL for Tomcat. More information is available here: http://tomcat.apache.org/tomcat-6.0-doc/ssl-howto.html
 

· You will need to change the localhost URLs in the datainfo.properties to match your desired server settings. If you are planning on using OpenClinica over the web, this will need to be your server’s or proxies URL and you may need to open the Tomcat port.  These SysURLs will be used in emails the application sends
 

· Enterprise support services, mailing lists, and additional resources for OpenClinica are available at http://www.openclinica.org.

 

10. Troubleshooting
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· If you encounter a screen similar to the one above, you can browse the tomcat logs in c:\oc\tomcat\logs to determine the source of the exception. This will help you troubleshoot the issue.
· For complete details about this release, and a list of known issues, please refer to the README.txt file.
11. Using Oracle as the Database 

OpenClnica 3.0.4 has been ported so it can work on the Oracle database as well as the PostgreSQL database.  We will not instruct you on how to install Oracle, but there are instructions on how to create the database OpenClinica will use.

Please go to the following wiki page for separate instructions for installing OpenClinica with Oracle.  http://www.openclinica.org/dokuwiki/doku.php?id=ocoracleinstall:start The document you find there should be followed instead of Chapters 4 and 7 above.
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